Kodiak H1 Mount, What have I done wrong?

Go down

Kodiak H1 Mount, What have I done wrong?

Post by Magload on 7/9/2018, 2:18 pm

I mounted my new Aimpoint H1 on my new 38 Super and all was well.  Had it sighted in but then read on this forum how much better the Kodiak Mount was so I bought one from KC.  Everything has gone down hill since then.  I just can not get it straight with the bore.  Full left adjustment and at 20yds benchrest it shoots 3" right.  I didn't want to leave it against the stop so backed it off where a 9 o'clock hold groups dead center.  What is the purpose of the little plate with the set screws.  Followed the instruction about how to tighten them but wonder if they will effect the scope alignment.  It is not the gun, or the rail as it was fine with a Matchdot II and the original T1 mount.  I have never had this problem mounting a scope before and been do it since I was knee high to a grasshopper.   HELP!  Don
avatar
Magload

Posts : 1174
Join date : 2016-11-18
Age : 71
Location : NE Florida

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by mikemyers on 7/9/2018, 4:13 pm

If it was me, I'd take it off the gun, make sure everything was clean, loosen all the screws as KC instructed, and see if it works out.  Maybe one of those set screws is preventing it from aligning properly?
avatar
mikemyers

Posts : 1279
Join date : 2016-07-26
Age : 74
Location : South Florida, and India

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by Magload on 7/9/2018, 4:52 pm

mikemyers wrote:If it was me, I'd take it off the gun, make sure everything was clean, loosen all the screws as KC instructed, and see if it works out.  Maybe one of those set screws is preventing it from aligning properly?
Mike I followed the instructions from KC and I did it with the steps you listed on another post.  It has been off and back on 3 times now.  Maybe a little difference between each time but still in the last rotation.  If I counted right there is 9 and 1/2 full turns from stop to stop on the windage turret and I should be near the middle not at the end.  I really don't think when someone ask me which hold I am using that I should be saying 9 O'clock hold, but then it did work petty well.  Don
avatar
Magload

Posts : 1174
Join date : 2016-11-18
Age : 71
Location : NE Florida

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by mikemyers on 7/9/2018, 4:58 pm

I just posted some new things you can check, any of which could potentially cause your problem.  It's all in the other thread.  

Can you post a photo of your rail, taken from the side?

Can you measure the width, and depth, of the rail?

I can compare it to my gun, which had the slots opened up considerably in both dimensions.  If you are doing everything correctly, then this is another possibility.  

I will try to take a photo of my rail from the side, but I'm away from my computer and it might be difficult to get a good photo.....
avatar
mikemyers

Posts : 1279
Join date : 2016-07-26
Age : 74
Location : South Florida, and India

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by LenV on 7/9/2018, 5:01 pm

Might be the cross screw not allowing the base to sit all the way down flat. square slot vs round slot or just bigger. I have several sets of rings that won't fit all my bases. I see Mike is saying pretty much the same thing. Picatiny vs Weaver

Len
avatar
LenV

Posts : 3220
Join date : 2014-01-24
Age : 68
Location : Oregon

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by mikemyers on 7/9/2018, 5:08 pm



avatar
mikemyers

Posts : 1279
Join date : 2016-07-26
Age : 74
Location : South Florida, and India

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by mikemyers on 7/9/2018, 5:11 pm

I think I have a "Clark" rail on my gun.  The three photos show the original "notch", and how another "notch" was opened up for the Aimpoint.

Yes, what LenV just wrote.  If that's the case, you should be able to feel the base "rocking" on the rail.

I have no idea who did the machining of the rail.  It looks bad in my hand, and looks even worse in my photos....
avatar
mikemyers

Posts : 1279
Join date : 2016-07-26
Age : 74
Location : South Florida, and India

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by LenV on 7/9/2018, 6:08 pm

I had a problem in Feb. when I tried to mount a Vortex scope on my Mk4. The base (similar to Kodiak) would not square up on the rail because it was only making contact on the ends of the mount and a little metal removed from the base to make it easier for brass extraction was messing it up bad. The tighter I cranked it the more it moved to the side. I ended up putting it on a different pistol.

http://www.bullseyeforum.net/t9250-vortex-crossfire-red-dot?highlight=vortex
avatar
LenV

Posts : 3220
Join date : 2014-01-24
Age : 68
Location : Oregon

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by Magload on 7/9/2018, 8:58 pm

I will try to open the rail slot up some more on the back side of the slot.  Sure looked like I opened it enough but a little more on the back of the slot won't hurt.  My invoice does not say what brand and model the rail is.  I like it as it has a slide racker as part of the rail.  I will take a pic tomorrow.  Don
avatar
Magload

Posts : 1174
Join date : 2016-11-18
Age : 71
Location : NE Florida

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by mikemyers on 7/9/2018, 10:28 pm

I left you a reply in the other thread.
avatar
mikemyers

Posts : 1279
Join date : 2016-07-26
Age : 74
Location : South Florida, and India

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by kc.crawford.7 on 7/18/2018, 9:31 am

Mag, it's a Rock River Arms slide mount.  You need to open the slot to .195 for clearance of the lock screw on the Kodiak mount.  It should be "deep" enough but has to be opened up for the Kodiak mount to sit properly.
avatar
kc.crawford.7

Posts : 435
Join date : 2012-12-09
Location : Maysville, NC

http://www.kcskustomcreations.com

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by Magload on 7/18/2018, 1:49 pm

kc.crawford.7 wrote:Mag, it's a Rock River Arms slide mount.  You need to open the slot to .195 for clearance of the lock screw on the Kodiak mount.  It should be "deep" enough but has to be opened up for the Kodiak mount to sit properly.
Thanks KC.  I am going to send you the H1 and shades next week.  I put the mount back on that came with the H1 and all is well right now.  I would like to shoot it some more before sending it to you.  I did open up the slot but maybe not enough I will measure it.  If one was to start counting slots from the back I am using S2.  Don
avatar
Magload

Posts : 1174
Join date : 2016-11-18
Age : 71
Location : NE Florida

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by Magload on 8/3/2018, 12:46 pm

Update.  fixed.  KC put the shades on the H1 and I got it back the other day.  Went ahead and put the Kodiak mount back on and with the shade you could see it was pointing way off to the left.  I had filed the slot to the size KC had said so I to the mount off and turned it around so the Kodiak name was on the left side.  Dumb me it worked fine that way.  Sighted it in today and it is great.  Love the new gun KC did a great job building the 38 Super.  I think I got the load down also but won't know till this weather gets out of the Feels like 105 and I start going to the 50yd range.  Don
avatar
Magload

Posts : 1174
Join date : 2016-11-18
Age : 71
Location : NE Florida

Back to top Go down

Re: Kodiak H1 Mount, What have I done wrong?

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum