Bullseye-L Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.

S&W Model 41 alibi

Page 2 of 2 Previous  1, 2

Go down

S&W Model 41 alibi - Page 2 Empty S&W Model 41 alibi

Post by djw1cav on 2/11/2020, 1:46 pm

First topic message reminder :

Last night I had an alibi with my S&W model 41.  It worked fine for slow and timed fire.  When I got to rapid fire (magazine #5) I pulled the trigger and nothing happened.  It felt like the safety was on but it was not.  A round was in the chamber.  My alibi was allowed.  I fired the next string of timed fire with magazine #6 and the pistol performed perfectly.  When it was time for my alibi string, I put a new round in magazine #5 and attempted to fire the string.  Again, nothing happened when I pulled the trigger, once again it felt like the safety was on but it was not.  At the time I had no clue what was wrong.  But after giving it some thought it sure looks like it is a magazine problem.

Before I tear into this I wanted to bounce this off of some of the more experienced model 41 users.
Has anyone else experienced this?  If so, how did you correct it?
Do I need to tweak something in the pistol or is it just a magazine problem?

note:
The pistol has 3000 rounds total thru it and 80 since cleaning.  I have never cleaned the magazines.

Doug

djw1cav

Posts : 121
Join date : 2015-04-06
Age : 71
Location : Illinois

Back to top Go down


S&W Model 41 alibi - Page 2 Empty Re: S&W Model 41 alibi

Post by Steve K on 2/13/2020, 10:29 pm

To clean the 41 frame I use Simple Green. After I take it from the solution I use the hottest tap water to rinse, place it in vegetable dehydrator, and finally lube it with Breakfree. I never had a rust problem.

Steve K

Posts : 67
Join date : 2015-11-09

Back to top Go down

S&W Model 41 alibi - Page 2 Empty Re: S&W Model 41 alibi

Post by r.tornello on 2/29/2020, 12:04 pm

Crud build up. It needs to be cleaned. The comment about the magazine not pushing the disconnector is something I had an issue with too. I took the grip off and watchhed how the firing system worked, or didn't. I put a fresh mag in and it worked. I also clean my mags after each practice in all my guns.

The 41 seems to like a very LIGHT lube and low viscosity. Otherwise the fire control system gums up after 200 to 300 rounds. That was one evening of practice for me.

Don Nygord said it: A clean gun (and that includes magazines) shoot better. If a dirty gun shot better, the manufacturer would sell them all crudded up.
r.tornello
r.tornello

Posts : 223
Join date : 2018-01-29
Location : Abell 520 Cluster

Back to top Go down

S&W Model 41 alibi - Page 2 Empty Re: S&W Model 41 alibi

Post by Sponsored content


Sponsored content


Back to top Go down

Page 2 of 2 Previous  1, 2

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum