Red dot mount fix.

Go down

Red dot mount fix. Empty Red dot mount fix.

Post by xringdave on Sat Mar 14, 2020 3:52 pm

Have a Clark 1911 and mounted a Clark scope mount on it. After sighting in at 50' I have no windage left and I'm still about 3/4" to the right.
I mounted a Burris Fastfire 2 on it.

xringdave

Posts : 109
Join date : 2014-06-14
Location : L.A. Calif.

Back to top Go down

Red dot mount fix. Empty Re: Red dot mount fix.

Post by james r chapman on Sat Mar 14, 2020 4:25 pm

You drilled and tapped the slide?
james r chapman
james r chapman
Admin

Posts : 3987
Join date : 2012-01-31
Age : 71
Location : HELL, Michigan

Back to top Go down

Red dot mount fix. Empty Re: Red dot mount fix.

Post by xringdave on Sat Mar 14, 2020 4:31 pm

james r chapman wrote:You drilled and tapped the slide?

Done by Clark in the early 80's.

xringdave

Posts : 109
Join date : 2014-06-14
Location : L.A. Calif.

Back to top Go down

Red dot mount fix. Empty Re: Red dot mount fix.

Post by james r chapman on Sat Mar 14, 2020 4:43 pm

I’m thinking your fast fire base is not seated fully on the rail before tightening

Isn’t the fast fire a picattiny rail base and the Clark a weaver base?
Sometimes clearance has to be added for the xbolt to fit correctly


Last edited by james r chapman on Sat Mar 14, 2020 4:46 pm; edited 1 time in total (Reason for editing : Added stuff)
james r chapman
james r chapman
Admin

Posts : 3987
Join date : 2012-01-31
Age : 71
Location : HELL, Michigan

Back to top Go down

Red dot mount fix. Empty Re: Red dot mount fix.

Post by Wobbley on Sat Mar 14, 2020 5:21 pm

Yes, the Fast Fires are Picatinny.
Wobbley
Wobbley

Posts : 2487
Join date : 2015-02-13

Back to top Go down

Red dot mount fix. Empty Re: Red dot mount fix.

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum